journal_geek:2021:2021-08-01-modification-securite-https

Modification de la sécurité pour la configuration https avec Apache 2.4

Modification de la configuration https

Lorsque j'ai rédigé le dossier Apache et plus particulièrement le chapitre concernant les connexions en https, le paramétrage était satisfaisant. Mais depuis, des évolutions imposent un changement dans la configuration SSL. Cela impacte les directives SSLCipherSuite et SSLProtocol.

Désormais, seul les protocoles TLS 1.2 et 1.3 sont admis. Malheureusement, je n'ai pas encore effectué le paramétrage pour le TLS 1.3 sur Debian 10. Donc seul le TLS 1.2 est activé.

Concernant les suites de Cipher autorisés, ils sont plus restricifs : ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:HIGH
Le reste est à proscrir : !RC4:!MD5:!aNULL:!EDH

Les pages concernées dans le guide ont été modifiées.

Entrer votre commentaire. La syntaxe wiki est autorisée:
  _      __  ____   __  __  _      __   __ __
 | | /| / / / __ \ / / / / | | /| / /  / // /
 | |/ |/ / / /_/ // /_/ /  | |/ |/ /  / _  / 
 |__/|__/  \___\_\\____/   |__/|__/  /_//_/
 
  • journal_geek/2021/2021-08-01-modification-securite-https.txt
  • Dernière modification: 2021/08/02 13:51
  • de Cédric ABONNEL